Storyfile Site is Down

Incident Report for StoryFile

Postmortem

Storyfile.com experienced an unusual spike in requests. We cannot confirm if malicious, however it only affected storyfile.com website and has been resolved.

Posted Mar 16, 2023 - 16:54 UTC

Resolved

We've resolved an issue with Storyfile Site.
Posted Mar 15, 2023 - 23:30 UTC

Identified

We've identified an issue with Storyfile Site. We are working to fix it
Posted Mar 15, 2023 - 23:25 UTC
This incident affected: Website.