Storyfile.com experienced an unusual spike in requests. We cannot confirm if malicious, however it only affected storyfile.com website and has been resolved.
Posted Mar 16, 2023 - 16:53 UTC
Resolved
This incident has been resolved.
Posted Mar 16, 2023 - 10:17 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 16, 2023 - 10:16 UTC
Identified
We've identified an issue with Storyfile Site. We are working to fix it