Storyfile Site is Down

Incident Report for StoryFile

Resolved

We've resolved an issue with Storyfile Site.
Posted May 02, 2025 - 19:10 UTC

Identified

We've identified an issue with Storyfile Site. We are working to fix it
Posted May 02, 2025 - 07:00 UTC
This incident affected: Website.